Delayed email delivery to Microsoft-hosted mailboxes (Outlook, Hotmail, Live, Microsoft 365)

Incident Report for Tribe CRM

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 16:34 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2026 - 14:34 CEST

Identified

We are aware of a delay affecting the delivery of emails sent to Microsoft-hosted mailboxes, including Outlook.com, Hotmail, Live, and Microsoft 365 addresses.

This is caused by a wider issue on Microsoft's side, which is temporarily deferring incoming messages with the response 451 4.7.500 Server busy. Please try again later.

What this means for you:
- Affected emails are not lost, rejected, or bounced.
- The recipient addresses are still valid.
- Our email provider automatically retries delivery, so messages should arrive once Microsoft's servers recover.

No action is needed on your part. We are actively monitoring the situation together with our email delivery partner and will update this page as it progresses.

We apologise for any inconvenience.
Posted Sep 04, 2026 - 14:31 CEST
This incident affected: Mail Service (Mailjet Outgoing SMTP).